読者です 読者をやめる 読者になる 読者になる

文系醫學生の記録

北海道大學醫學科學生井上大輔が書いてゐます.

installed ruby2.0 and zsh

mai@mai-ThinkPad-X40:~$ sudo apt-get install ruby2.0
[sudo] password for mai:
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
gir1.2-appindicator3-0.1 gir1.2-json-1.0 gir1.2-timezonemap-1.0
gir1.2-xkl-1.0 libtimezonemap1 python3-cairo python3-gi-cairo
これを削除するには 'apt-get autoremove' を利用してください。
以下の特別パッケージがインストールされます:
libjs-jquery libruby1.9.1 libruby2.0 libyaml-0-2 ruby ruby1.9.1
rubygems-integration
提案パッケージ:
javascript-common ri ruby-dev ruby1.9.1-examples ri1.9.1 graphviz
ruby1.9.1-dev ruby-switch bundler
以下のパッケージが新たにインストールされます:
libjs-jquery libruby1.9.1 libruby2.0 libyaml-0-2 ruby ruby1.9.1 ruby2.0
rubygems-integration
アップグレード: 0 個、新規インストール: 8 個、削除: 0 個、保留: 66 個。
5,734 kB のアーカイブを取得する必要があります。
この操作後に追加で 27.7 MB のディスク容量が消費されます。
続行しますか? [Y/n]
取得:1 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main libyaml-0-2 i386 0.1.4-3ubuntu3 [46.4 kB]
取得:2 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main libjs-jquery all 1.7.2+dfsg-2ubuntu1 [78.8 kB]
取得:3 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main ruby all 1:1.9.3.4 [5,334 B]
取得:4 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main ruby1.9.1 i386 1.9.3.484-2ubuntu1 [35.6 kB]
取得:5 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main libruby1.9.1 i386 1.9.3.484-2ubuntu1 [2,678 kB]
取得:6 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main libruby2.0 i386 2.0.0.484-1ubuntu2 [2,818 kB]
取得:7 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main ruby2.0 i386 2.0.0.484-1ubuntu2 [66.5 kB]
取得:8 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main rubygems-integration all 1.5 [5,340 B]
5,734 kB を 8秒 で取得しました (708 kB/s)
debconf: フロントエンドの初期化に失敗しました: Dialog
debconf: (Dialog フロントエンドはダムターミナル、emacs のシェルバッファ、もしくはユーザが制御しているターミナルではない場合には動作しません。)
debconf: フロントエンドをフォールバックします: Readline
以前に未選択のパッケージ libyaml-0-2:i386 を選択しています。
(データベースを読み込んでいます ... 現在 114564 個のファイルとディレクトリがインストールされています。)
Preparing to unpack .../libyaml-0-2_0.1.4-3ubuntu3_i386.deb ...
Unpacking libyaml-0-2:i386 (0.1.4-3ubuntu3) ...
以前に未選択のパッケージ libjs-jquery を選択しています。
Preparing to unpack .../libjs-jquery_1.7.2+dfsg-2ubuntu1_all.deb ...
Unpacking libjs-jquery (1.7.2+dfsg-2ubuntu1) ...
以前に未選択のパッケージ ruby を選択しています。
Preparing to unpack .../ruby_1%3a1.9.3.4_all.deb ...
Unpacking ruby (1:1.9.3.4) ...
以前に未選択のパッケージ ruby1.9.1 を選択しています。
Preparing to unpack .../ruby1.9.1_1.9.3.484-2ubuntu1_i386.deb ...
Unpacking ruby1.9.1 (1.9.3.484-2ubuntu1) ...
以前に未選択のパッケージ libruby1.9.1 を選択しています。
Preparing to unpack .../libruby1.9.1_1.9.3.484-2ubuntu1_i386.deb ...
Unpacking libruby1.9.1 (1.9.3.484-2ubuntu1) ...
以前に未選択のパッケージ libruby2.0:i386 を選択しています。
Preparing to unpack .../libruby2.0_2.0.0.484-1ubuntu2_i386.deb ...
Unpacking libruby2.0:i386 (2.0.0.484-1ubuntu2) ...
以前に未選択のパッケージ ruby2.0 を選択しています。
Preparing to unpack .../ruby2.0_2.0.0.484-1ubuntu2_i386.deb ...
Unpacking ruby2.0 (2.0.0.484-1ubuntu2) ...
以前に未選択のパッケージ rubygems-integration を選択しています。
Preparing to unpack .../rubygems-integration_1.5_all.deb ...
Unpacking rubygems-integration (1.5) ...
Processing triggers for man-db (2.6.7.1-1) ...
debconf: フロントエンドの初期化に失敗しました: Dialog
debconf: (Dialog フロントエンドはダムターミナル、emacs のシェルバッファ、もしくはユーザが制御しているターミナルではない場合には動作しません。)
debconf: フロントエンドをフォールバックします: Readline
Processing triggers for menu (2.1.46ubuntu1) ...
libyaml-0-2:i386 (0.1.4-3ubuntu3) を設定しています ...
libjs-jquery (1.7.2+dfsg-2ubuntu1) を設定しています ...
ruby (1:1.9.3.4) を設定しています ...
ruby1.9.1 (1.9.3.484-2ubuntu1) を設定しています ...
libruby1.9.1 (1.9.3.484-2ubuntu1) を設定しています ...
rubygems-integration (1.5) を設定しています ...
ruby2.0 (2.0.0.484-1ubuntu2) を設定しています ...
libruby2.0:i386 (2.0.0.484-1ubuntu2) を設定しています ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...
Processing triggers for menu (2.1.46ubuntu1) ...
mai@mai-ThinkPad-X40:~$ ruby
C-c C-cruby: Interrupt

mai@mai-ThinkPad-X40:~$ ruby -e 'puts 3 + 4'
7mai@mai-ThinkPad-X40:~$ ruby -e 'puts 3 + 4'
7
mai@mai-ThinkPad-X40:~$ ruby -v
ruby 1.9.3p484 (2013-11-22 revision 43786) [i686-linux]
mai@mai-ThinkPad-X40:~$ ruby2.0
C-c C-cruby2.0: Interrupt

mai@mai-ThinkPad-X40:~$ ruby2.0 -v
ruby 2.0.0p384 (2014-01-12) [i386-linux-gnu]
mai@mai-ThinkPad-X40:~$ ruby 2.1
ruby: No such file or directory -- 2.1 (LoadError)
mai@mai-ThinkPad-X40:~$sudo apt-get install zsh
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
gir1.2-appindicator3-0.1 gir1.2-json-1.0 gir1.2-timezonemap-1.0
gir1.2-xkl-1.0 libtimezonemap1 python3-cairo python3-gi-cairo
これを削除するには 'apt-get autoremove' を利用してください。
以下の特別パッケージがインストールされます:
zsh-common
提案パッケージ:
zsh-doc
以下のパッケージが新たにインストールされます:
zsh zsh-common
アップグレード: 0 個、新規インストール: 2 個、削除: 0 個、保留: 66 個。
2,683 kB のアーカイブを取得する必要があります。
この操作後に追加で 11.2 MB のディスク容量が消費されます。
続行しますか? [Y/n]
取得:1 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main zsh-common all 5.0.2-3ubuntu6 [2,119 kB]
取得:2 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main zsh i386 5.0.2-3ubuntu6 [564 kB]
2,683 kB を 3秒 で取得しました (831 kB/s)
debconf: フロントエンドの初期化に失敗しました: Dialog
debconf: (Dialog フロントエンドはダムターミナル、emacs のシェルバッファ、もしくはユーザが制御しているターミナルではない場合には動作しません。)
debconf: フロントエンドをフォールバックします: Readline
以前に未選択のパッケージ zsh-common を選択しています。
(データベースを読み込んでいます ... 現在 116476 個のファイルとディレクトリがインストールされています。)
Preparing to unpack .../zsh-common_5.0.2-3ubuntu6_all.deb ...
Unpacking zsh-common (5.0.2-3ubuntu6) ...
以前に未選択のパッケージ zsh を選択しています。
Preparing to unpack .../zsh_5.0.2-3ubuntu6_i386.deb ...
Unpacking zsh (5.0.2-3ubuntu6) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Processing triggers for man-db (2.6.7.1-1) ...
debconf: フロントエンドの初期化に失敗しました: Dialog
debconf: (Dialog フロントエンドはダムターミナル、emacs のシェルバッファ、もしくはユーザが制御しているターミナルではない場合には動作しません。)
debconf: フロントエンドをフォールバックします: Readline
zsh-common (5.0.2-3ubuntu6) を設定しています ...
zsh (5.0.2-3ubuntu6) を設定しています ...
update-alternatives: /bin/zsh (zsh) を提供するために 自動モード で /bin/zsh5 を使います
update-alternatives: /bin/rzsh (rzsh) を提供するために 自動モード で /bin/zsh5 を使います
update-alternatives: 警告: 関連する (リンクグループ rzsh の) ファイル /usr/share/man/man1/zsh.1.gz が存在しないので、/usr/share/man/man1/rzsh.1.gz の作成をスキップします
Processing triggers for menu (2.1.46ubuntu1) ...
mai@mai-ThinkPad-X40:~$

広告を非表示にする